Commit 9ae104e0 authored by Kolbjørn Barmen's avatar Kolbjørn Barmen
Browse files

Oppdatert til 1.6.5

parent c68771ef
radsecproxy (1.6.5-1) unstable; urgency=medium
* New upstream release.
* Bump Standards-Version to 3.9.6.
* Verify upstream's GPG signatures; add debian/upstream/signing-key.asc and
modify debian/watch accordingly.
* Minor adjustment to the long description. (Closes: #542454)
* Add --retry to --stop to fix spurious restart issue. Thanks to Michael
Vogt for the fix. (Closes: #711313)
* Add build dependency on dh-autoreconf and autoreconf during build time, as
it helps when adding new architectures to the archive. (Closes: #727952,
#744500)
* Add systemd unit file, along with the corresponding dh-systemd
integration.
* Switch pid file from /var/run to /run on both init script & systemd unit.
* Rewrite debian/copyright to the machine-parseable format.
-- Faidon Liambotis <paravoid@debian.org> Wed, 22 Oct 2014 23:50:56 +0300
radsecproxy (1.6.2-1) unstable; urgency=high radsecproxy (1.6.2-1) unstable; urgency=high
* Urgency set to high for a security release. * Urgency set to high for a security release.
......
...@@ -2,8 +2,12 @@ Source: radsecproxy ...@@ -2,8 +2,12 @@ Source: radsecproxy
Section: net Section: net
Priority: optional Priority: optional
Maintainer: Faidon Liambotis <paravoid@debian.org> Maintainer: Faidon Liambotis <paravoid@debian.org>
Build-Depends: debhelper (>= 9), autotools-dev, libssl-dev, nettle-dev, docbook2x Build-Depends: debhelper (>= 9), dh-autoreconf, dh-systemd,
Standards-Version: 3.9.3 autotools-dev,
libssl-dev,
nettle-dev,
docbook2x
Standards-Version: 3.9.6
Homepage: http://software.uninett.no/radsecproxy/ Homepage: http://software.uninett.no/radsecproxy/
Package: radsecproxy Package: radsecproxy
...@@ -11,9 +15,9 @@ Architecture: any ...@@ -11,9 +15,9 @@ Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends} Depends: ${shlibs:Depends}, ${misc:Depends}
Provides: radius-server Provides: radius-server
Description: RADIUS protocol proxy supporting RadSec Description: RADIUS protocol proxy supporting RadSec
A generic RADIUS proxy that in addition to usual RADIUS UDP transport also radsecproxy is a generic RADIUS proxy that in addition to usual RADIUS UDP
supports TLS (RadSec). It aims to be flexible while at the same time small in transport also supports TLS (RadSec). It aims to be flexible while at the same
size and memory footprint, efficient and easy to configure. time small in size and memory footprint, efficient and easy to configure.
. .
It can be useful as a proxy on site boundaries or in other complex RADIUS It can be useful as a proxy on site boundaries or in other complex RADIUS
routing topologies. It supports both IPv4 and IPv6. routing topologies. It supports both IPv4 and IPv6.
This package was debianized by Faidon Liambotis <paravoid@debian.org> on Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Sun, 14 Jun 2009 23:17:51 +0300 Upstream-Name: radsecproxy
Source: http://software.uninett.no/radsecproxy/
It was downloaded from: http://software.uninett.no/radsecproxy/
Files: *
Upstream Author: Linus Nordberg <linus@nordu.net> Copyright: 2006-2009 Stig Venaas <venaas@uninett.no>
2006-2010 UNINETT AS
Copyright: 2010-2012 NORDUnet A/S
Copyright (c) 2006-2009 Stig Venaas <venaas@uninett.no> License: GPL-2+ or BSD-3-clause
Copyright (c) 2006-2010 UNINETT AS Comment: for this binary distribution, only the BSD applies, as it links against OpenSSL
Copyright (c) 2010-2012 NORDUnet A/S
Files: debian/*
The Debian packaging is: Copyright: 2009-2014, Faidon Liambotis <paravoid@debian.org>
Copyright (C) 2009-2012 Faidon Liambotis <paravoid@debian.org> License: GPL-2+ or BSD-3-clause
License: License: GPL-2+
This package is free software; you can redistribute it and/or modify This package is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or the Free Software Foundation; either version 2 of the License, or
(at your option) any later version. (at your option) any later version.
.
This package is distributed in the hope that it will be useful, This package is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details. GNU General Public License for more details.
.
You should have received a copy of the GNU General Public License You should have received a copy of the GNU General Public License
along with this package; if not, write to the Free Software along with this package; if not, write to the Free Software
Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
.
On Debian systems, the complete text of the GNU General On Debian systems, the complete text of the GNU General
Public License version 2 can be found in `/usr/share/common-licenses/GPL-2'. Public License version 2 can be found in `/usr/share/common-licenses/GPL-2'.
Alternatively, you can use the following BSD-like license: License: BSD-3-clause
Redistribution and use in source and binary forms, with or without Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met: modification, are permitted provided that the following conditions are met:
* Redistributions of source code must retain the above copyright * Redistributions of source code must retain the above copyright
...@@ -43,7 +42,7 @@ Alternatively, you can use the following BSD-like license: ...@@ -43,7 +42,7 @@ Alternatively, you can use the following BSD-like license:
* Neither the name of the UNINETT AS nor the names of its * Neither the name of the UNINETT AS nor the names of its
contributors may be used to endorse or promote products derived contributors may be used to endorse or promote products derived
from this software without specific prior written permission. from this software without specific prior written permission.
.
THIS SOFTWARE IS PROVIDED BY UNINETT AS ``AS IS'' AND ANY THIS SOFTWARE IS PROVIDED BY UNINETT AS ``AS IS'' AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
...@@ -54,9 +53,3 @@ Alternatively, you can use the following BSD-like license: ...@@ -54,9 +53,3 @@ Alternatively, you can use the following BSD-like license:
ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
Please note that for the purpose of this distribution, only the BSD license
applies. This is due to the fact that this package is linking against the
OpenSSL library, which has conflicting terms with the GNU GPL and thus would
render the combined binaries as undistributable. The BSD license has no such
problems and hence this work can be legally distributed.
...@@ -16,7 +16,7 @@ PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin ...@@ -16,7 +16,7 @@ PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
DAEMON=/usr/sbin/radsecproxy DAEMON=/usr/sbin/radsecproxy
NAME="radsecproxy" NAME="radsecproxy"
DESC="RadSec proxy" DESC="RadSec proxy"
PIDFILE=/var/run/$NAME.pid PIDFILE=/run/$NAME.pid
. /lib/lsb/init-functions . /lib/lsb/init-functions
...@@ -41,7 +41,7 @@ case "$1" in ...@@ -41,7 +41,7 @@ case "$1" in
;; ;;
stop) stop)
log_daemon_msg "Stopping $DESC" "$NAME" log_daemon_msg "Stopping $DESC" "$NAME"
start-stop-daemon --stop --quiet --pidfile $PIDFILE \ start-stop-daemon --stop --retry 5 --quiet --pidfile $PIDFILE \
--exec $DAEMON --exec $DAEMON
case "$?" in case "$?" in
0) log_end_msg 0 ;; 0) log_end_msg 0 ;;
......
...@@ -2,7 +2,7 @@ ...@@ -2,7 +2,7 @@
#export DH_VERBOSE=1 #export DH_VERBOSE=1
%: %:
dh $@ dh $@ --with autoreconf,systemd
override_dh_auto_configure: override_dh_auto_configure:
dh_auto_configure -- --enable-fticks dh_auto_configure -- --enable-fticks
...@@ -18,3 +18,5 @@ override_dh_auto_install: ...@@ -18,3 +18,5 @@ override_dh_auto_install:
# and install a prepared config that works by default # and install a prepared config that works by default
rm -f debian/radsecproxy/etc/radsecproxy.conf-example rm -f debian/radsecproxy/etc/radsecproxy.conf-example
cp debian/radsecproxy.conf debian/radsecproxy/etc/radsecproxy.conf cp debian/radsecproxy.conf debian/radsecproxy/etc/radsecproxy.conf
.PHONY: override_dh_auto_configure override_dh_auto_install
[Unit]
Description=radsecproxy
ConditionPathExists=/etc/radsecproxy.conf
After=network.target
Documentation=man:radsecproxy(1)
[Service]
Type=forking
ExecStart=/usr/sbin/radsecproxy -i /run/radsecproxy.pid
PIDFile=/run/radsecproxy.pid
[Install]
WantedBy=multi-user.target
This diff is collapsed.
# Compulsory line, this is a version 3 file
version=3 version=3
opts="uversionmangle=s/-(alpha|beta)/~$1/" \ opts="uversionmangle=s/-(alpha|beta)/~$1/,pgpsigurlmangle=s/$/.asc/" \
http://software.uninett.no/radsecproxy/index.php?page=download radsecproxy-(.*)\.tar\.gz http://software.uninett.no/radsecproxy/index.php?page=download radsecproxy-(.*)\.tar\.gz
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment