Commit c575ee7c authored by Sigmund Augdal's avatar Sigmund Augdal

Only depend on scapy when on python2 since it doesn't work on python3 and not...

Only depend on scapy when on python2 since it doesn't work on python3 and not all uses of this module requires python3
parent 1f984135
import os
import sys
from setuptools import setup, find_packages
......@@ -12,8 +13,9 @@ requires = [
'mock',
'scvmm-client-py',
'pyroute2',
'scapy',
]
if sys.version_info[0] == 2:
requires.append('scapy')
setup(name='router-services',
version='0.16',
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment