modulesync 0.20.0

parent 94aa70ca
......@@ -7,9 +7,13 @@ spec/fixtures/manifests/
spec/fixtures/modules/
.vagrant/
.bundle/
.ruby-version
coverage/
log/
.idea/
.dependencies/
.librarian/
Puppetfile.lock
*.iml
.*.sw?
.yardoc/
modulesync_config_version: '0.16.11'
modulesync_config_version: '0.20.0'
docs/
pkg/
Gemfile.lock
Gemfile.local
vendor/
.vendor/
spec/fixtures/manifests/
spec/fixtures/modules/
.vagrant/
.bundle/
.ruby-version
coverage/
log/
.idea/
.dependencies/
.librarian/
Puppetfile.lock
*.iml
.*.sw?
.yardoc/
---
sudo: false
dist: trusty
language: ruby
cache: bundler
bundler_args: --without system_tests development
......@@ -7,7 +8,7 @@ before_install:
- bundle -v
- rm Gemfile.lock || true
- gem update --system
- gem install bundler -v '~>1.13.0'
- gem update bundler
- gem --version
- bundle -v
script:
......@@ -15,26 +16,18 @@ script:
matrix:
fast_finish: true
include:
- rvm: 1.9.3
env: PUPPET_VERSION="~> 3.0" STRICT_VARIABLES="yes" CHECK=test
- rvm: 1.9.3
env: PUPPET_VERSION="~> 3.0" STRICT_VARIABLES="yes" FUTURE_PARSER="yes" CHECK=test
- rvm: 2.1.9
env: PUPPET_VERSION="~> 3.0" STRICT_VARIABLES="yes" CHECK=test
- rvm: 2.1.9
env: PUPPET_VERSION="~> 4.0" CHECK=test
- rvm: 2.2.6
env: PUPPET_VERSION="~> 4.0" CHECK=test
- rvm: 2.3.3
env: PUPPET_VERSION="~> 4.0" CHECK=build DEPLOY_TO_FORGE=yes
- rvm: 2.3.3
env: PUPPET_VERSION="~> 4.0" CHECK=rubocop
- rvm: 2.3.3
env: PUPPET_VERSION="~> 4.0" CHECK=test
- rvm: 2.4.0
env: PUPPET_VERSION="~> 4.0" CHECK=test
allow_failures:
- rvm: 2.4.0
- rvm: 2.4.0
env: PUPPET_VERSION="~> 4.0" CHECK=rubocop
- rvm: 2.4.0
env: PUPPET_VERSION="~> 4.0" CHECK=build DEPLOY_TO_FORGE=yes
branches:
only:
- master
......
--markup markdown
--output-dir docs/
......@@ -11,7 +11,8 @@ def location_for(place, fake_version = nil)
end
group :test do
gem 'puppetlabs_spec_helper', '~> 1.2.2', :require => false
gem 'puppetlabs_spec_helper', '~> 2.0.1', :require => false
gem 'parallel_tests', :require => false
gem 'rspec-puppet', '~> 2.5', :require => false
gem 'rspec-puppet-facts', :require => false
gem 'rspec-puppet-utils', :require => false
......@@ -29,10 +30,12 @@ group :test do
gem 'redcarpet', :require => false
gem 'rubocop', '~> 0.47.0', :require => false if RUBY_VERSION >= '2.3.0'
gem 'rubocop-rspec', '~> 1.10.0', :require => false if RUBY_VERSION >= '2.3.0'
gem 'json_pure', '<= 2.0.1', :require => false if RUBY_VERSION < '2.0.0'
gem 'mocha', '>= 1.2.1', :require => false
gem 'coveralls', :require => false if RUBY_VERSION >= '2.0.0'
gem 'simplecov-console', :require => false if RUBY_VERSION >= '2.0.0'
gem 'coveralls', :require => false
gem 'simplecov-console', :require => false
gem 'github_changelog_generator', '~> 1.13.0', :require => false if RUBY_VERSION < '2.2.2'
gem 'rack', '~> 1.0', :require => false if RUBY_VERSION < '2.2.2'
gem 'github_changelog_generator', :require => false if RUBY_VERSION >= '2.2.2'
end
group :development do
......
......@@ -30,4 +30,15 @@ task test: [
:metadata_lint,
:release_checks,
]
begin
require 'github_changelog_generator/task'
GitHubChangelogGenerator::RakeTask.new :changelog do |config|
version = (Blacksmith::Modulefile.new).version
config.future_release = "#{version}"
config.header = "# Change log\n\nAll notable changes to this project will be documented in this file.\nEach new release typically also includes the latest modulesync defaults.\nThese should not impact the functionality of the module."
config.exclude_labels = %w{duplicate question invalid wontfix modulesync}
end
rescue LoadError
end
# vim: syntax=ruby
{
"name": "puppet-kafka",
"version": "2.3.1-rc0",
"version": "3.0.0-rc0",
"author": "Vox Pupuli",
"summary": "Puppet module for Kafka",
"license": "MIT",
......@@ -33,7 +33,6 @@
{
"operatingsystem": "CentOS",
"operatingsystemrelease": [
"5",
"6",
"7"
]
......@@ -41,7 +40,6 @@
{
"operatingsystem": "RedHat",
"operatingsystemrelease": [
"5",
"6",
"7"
]
......@@ -49,14 +47,12 @@
{
"operatingsystem": "Debian",
"operatingsystemrelease": [
"6",
"7"
]
},
{
"operatingsystem": "Ubuntu",
"operatingsystemrelease": [
"12.04",
"14.04"
]
}
......@@ -64,7 +60,7 @@
"requirements": [
{
"name": "puppet",
"version_requirement": ">= 3.8.7 < 5.0.0"
"version_requirement": ">= 4.6.1 < 5.0.0"
}
],
"tags": [
......
---
# This file is managed via modulesync
# https://github.com/voxpupuli/modulesync
# https://github.com/voxpupuli/modulesync_config
HOSTS:
centos-6-x64:
roles:
- master
platform: el-6-x86_64
box: centos/6
hypervisor: vagrant
CONFIG:
type: aio
...
# vim: syntax=yaml
---
# This file is managed via modulesync
# https://github.com/voxpupuli/modulesync
# https://github.com/voxpupuli/modulesync_config
HOSTS:
centos-7-x64:
roles:
- master
platform: el-7-x86_64
box: centos/7
hypervisor: vagrant
CONFIG:
type: aio
...
# vim: syntax=yaml
......@@ -10,7 +10,7 @@ HOSTS:
docker_preserve_image: true
docker_cmd: '["/usr/sbin/init"]'
docker_image_commands:
- 'yum install -y crontabs initscripts iproute openssl sysvinit-tools tar wget which'
- 'yum install -y crontabs initscripts iproute openssl sysvinit-tools tar wget which ss'
CONFIG:
trace_limit: 200
masterless: true
......
---
# This file is managed via modulesync
# https://github.com/voxpupuli/modulesync
# https://github.com/voxpupuli/modulesync_config
#
# Additional ~/.fog config file with AWS EC2 credentials
# required.
#
# see: https://github.com/puppetlabs/beaker/blob/master/docs/how_to/hypervisors/ec2.md
#
# Amazon Linux is not a RHEL clone.
#
HOSTS:
amazonlinux-2016091-x64:
roles:
- master
platform: centos-6-x86_64
hypervisor: ec2
# refers to image_tempaltes.yaml AMI[vmname] entry:
vmname: amazonlinux-2016091-eu-central-1
# refers to image_tempaltes.yaml entry inside AMI[vmname][:image]:
snapshot: aio
# t2.micro is free tier eligible (https://aws.amazon.com/en/free/):
amisize: t2.micro
# required so that beaker sanitizes sshd_config and root authorized_keys:
user: ec2-user
CONFIG:
type: aio
:ec2_yaml: spec/acceptance/nodesets/ec2/image_templates.yaml
...
# vim: syntax=yaml
# This file is managed via modulesync
# https://github.com/voxpupuli/modulesync
# https://github.com/voxpupuli/modulesync_config
#
# see also: https://github.com/puppetlabs/beaker/blob/master/docs/how_to/hypervisors/ec2.md
#
# Hint: image IDs (ami-*) for the same image are different per location.
#
AMI:
# Amazon Linux AMI 2016.09.1 (HVM), SSD Volume Type
amazonlinux-2016091-eu-central-1:
:image:
:aio: ami-af0fc0c0
:region: eu-central-1
# Red Hat Enterprise Linux 7.3 (HVM), SSD Volume Type
rhel-73-eu-central-1:
:image:
:aio: ami-e4c63e8b
:region: eu-central-1
# SUSE Linux Enterprise Server 12 SP2 (HVM), SSD Volume Type
sles-12sp2-eu-central-1:
:image:
:aio: ami-c425e4ab
:region: eu-central-1
# Ubuntu Server 16.04 LTS (HVM), SSD Volume Type
ubuntu-1604-eu-central-1:
:image:
:aio: ami-fe408091
:region: eu-central-1
# Microsoft Windows Server 2016 Base
windows-2016-base-eu-central-1:
:image:
:aio: ami-88ec20e7
:region: eu-central-1
---
# This file is managed via modulesync
# https://github.com/voxpupuli/modulesync
# https://github.com/voxpupuli/modulesync_config
#
# Additional ~/.fog config file with AWS EC2 credentials
# required.
#
# see: https://github.com/puppetlabs/beaker/blob/master/docs/how_to/hypervisors/ec2.md
#
HOSTS:
rhel-73-x64:
roles:
- master
platform: el-7-x86_64
hypervisor: ec2
# refers to image_tempaltes.yaml AMI[vmname] entry:
vmname: rhel-73-eu-central-1
# refers to image_tempaltes.yaml entry inside AMI[vmname][:image]:
snapshot: aio
# t2.micro is free tier eligible (https://aws.amazon.com/en/free/):
amisize: t2.micro
# required so that beaker sanitizes sshd_config and root authorized_keys:
user: ec2-user
CONFIG:
type: aio
:ec2_yaml: spec/acceptance/nodesets/ec2/image_templates.yaml
...
# vim: syntax=yaml
---
# This file is managed via modulesync
# https://github.com/voxpupuli/modulesync
# https://github.com/voxpupuli/modulesync_config
#
# Additional ~/.fog config file with AWS EC2 credentials
# required.
#
# see: https://github.com/puppetlabs/beaker/blob/master/docs/how_to/hypervisors/ec2.md
#
HOSTS:
sles-12sp2-x64:
roles:
- master
platform: sles-12-x86_64
hypervisor: ec2
# refers to image_tempaltes.yaml AMI[vmname] entry:
vmname: sles-12sp2-eu-central-1
# refers to image_tempaltes.yaml entry inside AMI[vmname][:image]:
snapshot: aio
# t2.micro is free tier eligible (https://aws.amazon.com/en/free/):
amisize: t2.micro
# required so that beaker sanitizes sshd_config and root authorized_keys:
user: ec2-user
CONFIG:
type: aio
:ec2_yaml: spec/acceptance/nodesets/ec2/image_templates.yaml
...
# vim: syntax=yaml
---
# This file is managed via modulesync
# https://github.com/voxpupuli/modulesync
# https://github.com/voxpupuli/modulesync_config
#
# Additional ~/.fog config file with AWS EC2 credentials
# required.
#
# see: https://github.com/puppetlabs/beaker/blob/master/docs/how_to/hypervisors/ec2.md
#
HOSTS:
ubuntu-1604-x64:
roles:
- master
platform: ubuntu-16.04-amd64
hypervisor: ec2
# refers to image_tempaltes.yaml AMI[vmname] entry:
vmname: ubuntu-1604-eu-central-1
# refers to image_tempaltes.yaml entry inside AMI[vmname][:image]:
snapshot: aio
# t2.micro is free tier eligible (https://aws.amazon.com/en/free/):
amisize: t2.micro
# required so that beaker sanitizes sshd_config and root authorized_keys:
user: ubuntu
CONFIG:
type: aio
:ec2_yaml: spec/acceptance/nodesets/ec2/image_templates.yaml
...
# vim: syntax=yaml
---
# This file is managed via modulesync
# https://github.com/voxpupuli/modulesync
# https://github.com/voxpupuli/modulesync_config
#
# Additional ~/.fog config file with AWS EC2 credentials
# required.
#
# see: https://github.com/puppetlabs/beaker/blob/master/docs/how_to/hypervisors/ec2.md
#
HOSTS:
windows-2016-base-x64:
roles:
- master
platform: windows-2016-64
hypervisor: ec2
# refers to image_tempaltes.yaml AMI[vmname] entry:
vmname: windows-2016-base-eu-central-1
# refers to image_tempaltes.yaml entry inside AMI[vmname][:image]:
snapshot: aio
# t2.micro is free tier eligible (https://aws.amazon.com/en/free/):
amisize: t2.micro
# required so that beaker sanitizes sshd_config and root authorized_keys:
user: ec2-user
CONFIG:
type: aio
:ec2_yaml: spec/acceptance/nodesets/ec2/image_templates.yaml
...
# vim: syntax=yaml
......@@ -9,7 +9,7 @@ HOSTS:
fedora-25-x64:
roles:
- master
platform: fedora-24-x86_64
platform: fedora-25-x86_64
box: fedora/25-cloud-base
hypervisor: vagrant
CONFIG:
......
......@@ -2,7 +2,7 @@ require 'puppetlabs_spec_helper/module_spec_helper'
require 'rspec-puppet-facts'
include RspecPuppetFacts
if Dir.exist?(File.expand_path('../../lib', __FILE__)) && RUBY_VERSION !~ %r{^1.9}
if Dir.exist?(File.expand_path('../../lib', __FILE__))
require 'coveralls'
require 'simplecov'
require 'simplecov-console'
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment