Update based on voxpupuli/modulesync_config 0.16.11

parent 066d7a5b
modulesync_config_version: '0.16.8'
modulesync_config_version: '0.16.11'
......@@ -518,3 +518,7 @@ RSpec/RepeatedDescription:
RSpec/NestedGroups:
Enabled: False
# disable Yaml safe_load. This is needed to support ruby2.0.0 development envs
Security/YAMLLoad:
Enabled: false
......@@ -7,7 +7,7 @@ before_install:
- bundle -v
- rm Gemfile.lock || true
- gem update --system
- gem update bundler
- gem install bundler -v '~>1.13.0'
- gem --version
- bundle -v
script:
......
......@@ -24,8 +24,8 @@ RSpec.configure do |c|
puppetversion: Puppet.version,
facterversion: Facter.version
}
default_facts.merge!(YAML.safe_load(File.read(File.expand_path('../default_facts.yml', __FILE__)))) if File.exist?(File.expand_path('../default_facts.yml', __FILE__))
default_facts.merge!(YAML.safe_load(File.read(File.expand_path('../default_module_facts.yml', __FILE__)))) if File.exist?(File.expand_path('../default_module_facts.yml', __FILE__))
default_facts.merge!(YAML.load(File.read(File.expand_path('../default_facts.yml', __FILE__)))) if File.exist?(File.expand_path('../default_facts.yml', __FILE__))
default_facts.merge!(YAML.load(File.read(File.expand_path('../default_module_facts.yml', __FILE__)))) if File.exist?(File.expand_path('../default_module_facts.yml', __FILE__))
c.default_facts = default_facts
end
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment